Lubię psuć, aby się uczyć… czyli znikające menu

Facebooktwittergoogle_plusredditpinterestlinkedintumblrmailFacebooktwittergoogle_plusredditpinterestlinkedintumblrmail

Czasami coś w swoim testowym (powtarzam – testowym) serwisie opartym na joomla! zepsuje, czy to celowo, czy też niechcący – ale zawsze choć raz w tygodniu. Dziś był ten dzień. Zainstalowałem komponent Advanced Administrator Menu (theartofjoomla.com) – służy on do stworzenia nowego menu dla administratorów Joomla! – ot ten góry pasek menu.

Uwaga spolszczenie dostępne jest na forum.joomla.pl – w dziale tłumaczenia. Można sobie fajnie pewne rzeczy poukładać, jak ktoś ma czas, chęci i wyższy cel. Przy okazji wyłącza się “stare” menu i ma się tylko nowe. Ja znudzony tym komponentem stwierdziłem, było fajnie, ale pora się rozstać i odinstalowałem. Oczywiście niemalże natychmiast mój wzrok dał wyraźny sygnał do mózgu, coś jest nie tak z twoją joomla! i oczywiście, że tak, znikło menu górne. I teraz powinienem zapłakać, kopnąć krzesło etc… bo jak tu uaktywnić “stare” menu skoro nie mam jak wejść do modułów dla administratora. Łatwizna pomyślałem, zalogowałem się do innej mojej strony, skopiowałem adres: /administrator/index.php?option=com_modules&client=1   i wkleiłem do mojej “zepsutej” joomla!  i już mogłem włączyć (opublikować) menu – bez problemu. Ah, dobrze jest mieć 2 różne strony (roboczą i produkcyjną) na tym samym hostingu, aby zabawa była uczciwa i bezpieczna. Zresztą czy ja o tym nie pisałem w mojej… <cenzura, autor chciał zareklamować swoją najnowszą książkę>.

Tags:
  • Ja w takich wypadkach grzebię po tabelach. 🙂 Kiedyś zainstalowałem sobie potwierdzanie logowania do panelu administracyjnego kodem z maila, wcześniej wyłączając możliwość wysłania maila przez joomle.