Błąd. Nie znalazłem pliku instalacyjnego (XML)…

Facebooktwittergoogle_plusredditpinterestlinkedintumblrmailFacebooktwittergoogle_plusredditpinterestlinkedintumblrmail

Zapewne każdy z nas instalując kiedyś dodatek, komponent spotkał się z takim komunikatem. Tak potwierdzam, także mi zdarzyło się to kilka razy, mimo, iż moje hostingi są ze średniej półki cenowej. W przypadku hostingów darmowych i niska półka cenowa, przyczyn tego stanu rzeczy może być bardzo wiele, poczynając od nieśmiertelnych złych praw do folderu np. tmp oraz docelowego.

W moim przypadku problem tkwił gdzieś indziej, a mianowicie zbyt dużym skompresowaniu pliku .zip. Czyli dodatkowa podpowiedź, w postaci:  „…Być może pakiet jest podwójnie skompresowany” – był częściowo prawdziwy. Co zrobiłem, po prostu rozpakowałem paczkę, w moim przypadku plik „plg_jce_152.zip” – i ponownie spakowałem do formatu ZIP, ale tym razem o poziomie kompresji najmniejszym. Czyli z pierwotnych 654KB, zrobiło się 677KB i … zainstalowało się bez najmniejszych problemów.

Osoby, które pobierają pliki rozszerzeń z różnych „szemranych” miejsc, czasem też mają problemy z instalacją plików. Najczęściej spowodowane jest to z kilkoma rzeczami, np.:

  • paczka została spakowana za pomocą formatu RAR (często chronionego za pomocą hasła) -> rozpakować pliki, aż uzyskamy pojedyncze pliki zip;
  • rozszerzenie nie jest przeznaczone dla tej wersji Joomla!, czyli może być tylko dla starej wersji J! 1.0.x -> czasami włączenie dodatku System – Legacy (Włącz tryb zgodności) jest w stanie pomóc;
  • rozszerzenie lub plik jest uszkodzony, tu niestety nic nie jesteś w stanie pomóc, oprócz zakupienia LEGALNEJ wersji dodatku/komponentu.
  • Kordian

    Nie pomogło nie pakowanie, problem również z JCE. Rozpakowane przerzuciłem ftpem do tmp i dopiero instalator raczył zadziałać 😉