Joomla! 1.7 – stabilna i bezpieczna (aktualizacja)

Facebooktwittergoogle_plusredditpinterestlinkedintumblrmailFacebooktwittergoogle_plusredditpinterestlinkedintumblrmail

Zgodnie z nowym cyklem wydawniczym wczoraj pojawiła się Joomla! 1.7. Jest to wydanie stabilne, a co najważniejsze z załataną dziurą bezpieczeństwa (luka XSS), którą dotkniete są poprzednie wersje 1.6.x. Tym samym zespół odpowiedzialny za nowe wydanie sugeruje, a wręcz zaleca wszystkim administratorom aktualizacje. Tak mamy tu bowiem do czynienia z aktualizacją, a nie migracją jak było poprzednio. Spolszczenie wykonane dla wersji RC oczywiście pasuje, ale PCJ pracuje już nad kolejną wersją.

Aktualizacja !  uwaga jest już Joomla 1.7.1

Kolejna wersja Joomla! tym razem 1.8 (jednak v2.5!) planowana jest na styczeń/luty jeśli wierzyć doniesieniom.

Aktualnie wszystkie firmy web developerskie związane z Joomla! pracują bardzo intensywnie m.in. Gavick.com – aby dostarczyć swoim klientom szablony zgodne z najnowszym wydaniem Joomla! 1.7. Pewna część firm będzie nadal budować szablony dla Joomla! 1.5 i równocześnie dla 1.7, zupełnie pomijając 1.6, co zrozumiałe. Ponieważ J1.5 będzie wspierana aż do kwietnia 2012.

Więcej informacji co się zmieniło znajdziesz na oficjalnej stronie joomla.org . Przed aktualizacją zapoznaj się z  update instructions .

Uwaga,  jeśli podczas aktualizacji zobaczysz błąd „Fatal error: Cannot instantiate abstract class JDatabaseQuery”  <- zapoznaj się z tym artykułem.