Joomla! 1.6 BETA 1 – dostępna!

Facebooktwittergoogle_plusredditpinterestlinkedintumblrmailFacebooktwittergoogle_plusredditpinterestlinkedintumblrmail

Po długim oczekiwaniu, Joomla! 1.6 BETA 1 – została przekazana dla społeczności. Ta wersja pojawia się po prawie 7 miesiącach od kiedy Joomla! 1.6 Alpha 2 została wydana. To był dla nas długi okres – ale jak się wydaje – było warto.

Ta wersja beta oznacza ogromny krok naprzód w rozwoju Joomla! 1.6. Funkcje zawarte w tej wersji są to te, które znajdują się w końcowej, stabilnej wersji. Czy będzie system komentarzy? Nie, z tego co udało mi się dowiedzieć, dopiero w wersji 1.7 pojawi się ta funkcjonalność. Myślę, że z uwagi na dużą ilość komponentów nie ma co rozpaczać, ważniejsze są inne ciekawsze nowości:

  • Nowy Access Control System (ACL) – pozwoli administratorowi kontrolować (realnie) kto może oglądać oraz zarządzać zawartością strony, zarówno od strony frontowej, jak i administracyjnej.
  • Unlimited Depth Organizational Model (nested categories) – pozbyto się sekcji na rzecz rozbudowanych kategorii.
  • One-Click Extension Updates – upraszcza proces aktualizacji rozszerzeń.
  • Semantic XHTML Layouts (templates) – jeszcze lepszy jakościowo kod szablonów i generowanych w ten sposób stron.

AKTUALIZACJA:
Dziś rano można już było zauważyć na blogach branżowych niezwykłe poruszenie, ale i głosy krytyczne (link). Nie oszukujmy się nowości, które wprowadza 1.6 – są już znane w wielu CMS od lat. Szkoda, że od tego nie zaczęto, a przynajmniej w części w J! 1.5. Głównie rozchodzi się o ACL. Niestety nadal Joomla! nie posiada kilku wbudowanych opcji, tak jak chociażby WordPress (np. komentarze + aktualizacja po kliknięciu). Jednak nie ma co za bardzo marudzić, jest coraz lepiej.

  • rotsap

    Joomla 1.6 jak rozumiem nie będzie kompatybilna z Joomlą 1.5. Jesli nie będzie to będzie to najbardziej wkurzająca rzecz w samej Joomla, Dokładnie chodzi mi o rozszerzenia. Poza tym znowu trzeba się będzie uczyć budowy szablonów od podstaw itd. „Dżizas”

  • Łukasz

    Dlaczego u mnie zamiast normalnych teksów wyświetla się coś typu „COM_LOGIN_VALID”?

  • ? Nie wiem u mnie było okey, hihi. Może pliki językowe się nie przegrały.