VirtueMart 2.6 – dobre i złe wieści

Facebooktwittergoogle_plusredditpinterestlinkedintumblrmailFacebooktwittergoogle_plusredditpinterestlinkedintumblrmail

vm-2014-joomlaTeraz od kiedy Joomla! 3.3 beta2 została oficjalnie opublikowana czas na to, aby rozszerzenia także wydały nowe – uaktualnione wersje. W poprzednim tygodniu zaprezentowany został komponent VirtueMart v.2.6, co mogło być pewnym zakoczeniem, szczególnie jeśli chodzi o numeracje wersji. Jeśli chodzi o funkcjonalność, nic szczególnego nie dodano, głównie poprawki – ale jedna rzecz uległa radykalnej zmianie, a mianowicie minimalne wymagania jeśli chodzi o wersje PHP. Teraz komponent wymaga do poprawnej pracy (instalacji) PHP v5.3.10 – z pewnością podyktowane jest to przygotowaniami do długo oczekiwanej wersji 3.0, która w końcu wprowadzi zgodność z Joomla! 3.x. Co mają zatem zrobić osoby, które nadal tkwią w czasach PHP 5.2 (rok 2009), pozostać na starej wersji, albo zmienić hosting.

Jest to coś na co twórcy stron opartych na  Joomla czekali długo, często właśnie ten czynnik powodował frustracje i złość (widziałem reakcje na forum), a także fakt, że nadal powstawały(ją) strony-sklepy na Joomla 2.5, mimo istnienia Joomla! 3.2.x. Czy VM wersja 2.6 zatem działa pod J3.x – jeszcze nie! Zatem musisz uzbrobić się w kolejne pokłady cierpliwości.

Oczywiście nadchodząca wersja VM to nie tylko poprawki i tryb zgodności, ale z pewnością kilka nowych funkcjonalności, które „wymusza” rynek ecommerce.  Z tą wersją twórcy VirtueMart wprowadzą również nową strategię wsparcia wraz z kompatybilność wsteczną, co jest bardzo ekscytujące.Pełna lista nowych funkcji oraz lista poprawek błędów dostępna jest na stronie projektu: VirtueMart VM2.6.