Po aktualizacji do Joomla 2.5.10 (2.5.11) pojawił się błąd 404 po użyciu przełącznika flag

Facebooktwittergoogle_plusredditpinterestlinkedintumblrmailFacebooktwittergoogle_plusredditpinterestlinkedintumblrmail

bład 404 - joomla 2.5.11 - flagi jezykoweNiestety, stało się, jedno naprawili inne zepsuli – jak mawiają. Po aktualizacji do Joomla 2.5.10 lub od razu Joomla 2.5.11 – obsługa stron wielojęzycznych legła w gruzach, po kliknięciu na flagi – otrzymasz błąd (error 404). Problem dotyczy zatem tylko i wyłącznie artykułów, inne komponenty nadal są posłuszne, podobnie jak moduły. Błąd wykryto dwa dni temu i do tej pory nie ma sensownego wytłumaczenia ani skutecznej poprawki. Należy przypuszczać, że z pewnością pojawi się wkrótce (wraz z Joomla 2.5.12 ?), a do tego czasu radzę ….
Przy okazji czytania wpisów dowiedziałem się, że ów błąd dotyczy również stron opartych na zaktualizowanym Joomal 3.1.

Zapewne zapytacie, czy ów problem dotyczy wszystkich instalacji Joomla, otóż nie do końca. A to z tej prostej przyczyny, że większość szablonów napisuje jeden z  plików (poniżej) odpowiedzialnych za wyświetlanie artykułów, stąd też problem ich nie dotyczy, ufff. Dlatego też błąd ten wykryto z opóźnieniem.

ROZWIĄZANIE (tymczasowe), ale skuteczne:

Wykorzystać (nadpisać) nowy plik (components/com_content/models/article.php) – starym pochodzącym z Joomla 2.5.9.

p.s.

Wątek an oficjalnym forum joomla: http://forum.joomla.org/viewtopic.php?f=615&t=800337
Zgłoszony błąd: http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&tracker_item_id=30724

 

  • kulfi82

    Dwa dni z tym walczyłem. Takie sytuacje zniechęcają do szybkich aktualizacji. 🙁

  • Krzysiek

    Dziwne u mnie wszystko śmiga żadnych błędów przy przełączaniu języka